User Tools

Site Tools


install:upgrade:stable-to-devel

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
install:upgrade:stable-to-devel [2017/01/10 14:46]
miconda [Core]
install:upgrade:stable-to-devel [2020/07/17 08:41] (current)
miconda [Upgrade Kamailio from v5.4.x to v5.5.0 (devel)]
Line 1: Line 1:
-====== Upgrade Kamailio from v4.4.x to v5.0.0 (devel) ======+====== Upgrade Kamailio from v5.4.x to v5.5.0 (devel) ======
  
-The page contains the details about the changes that were made to old components during the development of v5.0.0 compared with what existed in v4.4.x. It does not include the brand new modules, focusing on how to upgrade database and configuration file from v4.4.x to run with Kamailio devel.+The page contains the details about the changes that were made to old components during the development of v5.5.0 compared with what existed in v5.4.x. It does not include the brand new modules, focusing on how to upgrade database and configuration file from v5.4.x to run with Kamailio 5.5.0.
  
 ===== Previous Stable Release ===== ===== Previous Stable Release =====
Line 7: Line 7:
 If you look for the guidelines to upgrade to previous stable release, see: If you look for the guidelines to upgrade to previous stable release, see:
  
-  * [[install:upgrade:4.3.x-to-4.4.0|Upgrade Kamailio v4.3.x to v4.4.0]]+  * [[install:upgrade:5.3.x-to-5.4.0|Upgrade Kamailio v5.3.x to v5.4.0]]
  
 ===== Remarks ===== ===== Remarks =====
Line 16: Line 16:
   * CPM - the change was used with the new value via explicit parameter in default config file from old releases   * CPM - the change was used with the new value via explicit parameter in default config file from old releases
   * RCM - the change is recommended to be done if you had an explicit different or lower value for this parameter in old config   * RCM - the change is recommended to be done if you had an explicit different or lower value for this parameter in old config
 +  * UPG - the change has to be done, older config does not work any longer
  
 ===== Modules ===== ===== Modules =====
  
-==== Removed Modules ====+==== Upgraded Modules ====
  
-=== mi_datagram ===+  * none
  
-The **jsonrpcs** module can be used instead to execute RPC commands over datagram sockets (unix socket file, IPv4 or IPv6).+==== Removed Modules ====
  
-=== mi_fifo === +  none
- +
-The **jsonrpcs** module can be used instead to execute RPC commands over a FIFO file. +
- +
-=== mi_xmlrpc === +
- +
-The **xmlrpc** module can be used instead to execute RPC commands over HTTP/S XMLRPC. +
- +
-=== pua_mi === +
- +
-The **pua_rpc** module can be used instead to trigger presence PUBLISH or SUBSCRIBE requests via RPC commands.+
  
 ==== Renamed Modules ==== ==== Renamed Modules ====
  
-The module that had a '-' (dash/minus) in the name were renamed to remove it, respectively:+  * none
  
-  * cpl-c => cplc 
-  * janssonrpc-c => jsonrpcc 
-  * jsonrpc-c => jsonrpcc 
-  * jsonrpc-s => jsonrpcs 
 ===== Internal Libraries ===== ===== Internal Libraries =====
  
-==== kcore ==== 
- 
-The library has been removed. 
- 
-Parts of its code have been removed or merged into other components. 
- 
-==== kmi ==== 
- 
-The library has been removed. 
- 
-The entire Management Interface (MI) code was removed. Instead of MI commands use RPC commands. The tool **kamctl** is using now RPC commands via **jsonrpcs** module. 
  
 ===== Core ===== ===== Core =====
  
 ==== Parameters ==== ==== Parameters ====
 +
 +==== Misc ====
  
 ===== Database ===== ===== Database =====
Line 68: Line 46:
 ==== MySQL Database Structure ==== ==== MySQL Database Structure ====
  
-Run following SQL statements in MySQL client to upgrade database structure from v4.4 to v5.0:+Run following SQL statements in MySQL client to upgrade database structure from v5.4 to v5.5:
  
 <code sql> <code sql>
---table: sca_subscriptions +...
-ALTER TABLE sca_subscriptions +
-  ADD COLUMN server_id INTEGER DEFAULT 0 NOT NULL, +
-  DROP INDEX sca_expires_idx, +
-  ADD INDEX sca_expires_idx (server_id, expires); +
-UPDATE version SET table_version=2 WHERE table_name="sca_subscriptions";+
 </code> </code>
install/upgrade/stable-to-devel.1484055987.txt.gz · Last modified: 2017/01/10 14:46 by miconda